Subject: Re: HW 2 program question

From: Chee Yap <[email-masked]>
Date: Mon, 4 Oct 1999 08:55:52 -0400 (EDT)

Bram,

thanks for the alert.  I will cc this
response to the whole class.

Note to the rest of class:
the function "readString" which we provided
for your hw2 assumes that each line
of the input file ends with the
following 2-character sequence:

	"\r\n"

(\r is [carriage-return] and \n is [newline] character).
As Bram points out below, on some operating system,
the sequence may be difference.  On Bram's linux,
each line terminates with the sequence "\n" only.

So the question arises: what should your code assume
when you hand it in?  Here is what I want you to do:

	--keep readString as we have defined it.
	--if your system has a different line termination
		convention, I ask you to write the obvious
		variant of readString, but call it "myReadString".
	--you should test your code using "myReadString" but
		when you hand in your program, please revert
		back to "readString" so that we can test your
		program conveniently.  [However, remember to
		leave "myReadString" in the program for us to check]

Hope this is clear,
--Chee

> From [email-masked] Sat Oct  2 16:54 EDT 1999
> Date: Sat, 02 Oct 1999 20:59:49 +0000
> From: Bram Sterling <[email-masked]>
> To: [email-masked]
> Subject: HW 2 program question
> 
> Proffesor
>     I am programing under linux, and your file input code does not work
> properly because it assumes carriage return + line feed newlines, but
> linux uses line feed only.  Should I hand in a version with your
> origonal file input code, or one with linux style input?  Also, this
> could affect other students who use linux.
> 
> Thank you
> 
> Bram Sterling
> 
> 
>

---

From: Chee Yap <[email-masked]>
Date: Tue, 5 Oct 1999 10:28:17 -0400 (EDT)

Greg,

Actually, I tested my functions on unix and
on my win95, and they both works.  So the difference is
really one between linux and unix!

It is true that unix is official, but whenever
possible, I try to accomodate any other systems.
[I doubt I will encounter such a situation though]

I gave out this information in case you
are testing your programs on a system that
has different conventions (apparently MAC has
another convention, but I have not heard from
anyone using MACs about this).

--Chee

> From [email-masked] Tue Oct  5 01:34 EDT 1999
> From: "Gregory C Frank" <[email-masked]>
> To: "Chee Yap" <[email-masked]>
> Subject: Re: HW 2 program question
> Date: Tue, 5 Oct 1999 01:31:08 -0400
> X-Priority: 3
> X-MSMail-Priority: Normal
> X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
> 
> Prof.
> 
> You said in class that the main OS the class is based on is Unix. Why then
> are we programming for \r\n if that is strictly a PC-only phenomenon.
> 
> Greg
> 
> ----- Original Message -----
> From: Chee Yap <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Monday, October 04, 1999 8:55 AM
> Subject: Re: HW 2 program question
> 
> 
> >
> > Bram,
> >