Subject: Re: zero problem

From: Mohip Joarder <[email-masked]>
Date: Wed, 10 Nov 1999 14:42:30 -0500 (EST)

i just went to archi to clear the problem up. it turns out that you can't
compile this on acf5 because there's something wrong with the java
compiler. that's why people have been getting the ZERO problem. compile on
omicron or go see archi.

mo

On Wed, 10 Nov 1999, Mark Vovsi wrote:

> Very mysterious ... because the same exact code works for me. Is your
> multiply method static?
> - Mark
> 
> On Wed, 10 Nov 1999, Ngo Fung Chan wrote:
> 
> > Hi,
> >      mult.java:28: Variable ZERO in class java.math.BigInteger not
> > accessible from cl
> > ass mult.
> >       return BigInteger.ZERO;
> > 
> >       I don't know why I cannot return this constant. I have already
> > inclueded the class BigInteger. Do anyone know how to fix this?
> >      Thank you.
> > 
> > Ngo Chan
> > 
>

---

From: Archisman Rudra <[email-masked]>
Date: Wed, 10 Nov 1999 15:13:33 -0500 (EST)

It seems that you will get this problem if you work in acf5 or
in an improperly set up java distribution elsewhere (home PC).
The omicron account seems to be properly set up in this respect.
I was getting this problem even on the public SUNs of the cs department.

-- Archi